Administration

10. März 2021

Mittwoch, März 10, 2021

Mailserver okay - Thunderbird gefixt

Nachdem ich vor einiger Zeit meinen Mailserver von Debian 9 auf Debian 10 angehoben hatte, ging einiges plötzlich nicht mehr. Einige Änderungen an Zertifikaten und anderen Sicherheitsmechanismen hatten dazu geführt, dass ich keine Mails mehr im Thunderbird von meinem privaten Mailserver abrufen konnte. Eine Zeit lang habe ich mich damit beholfen, dass ich die Mails direkt auf dem Server abgerufen habe, was zugegebnermaßen nicht so ganz trivial ist, wenn man keinen Standardpfad benutzt und keinen lokalen Mailclient eingerichtet hat. Darum ist es eher einem Zufall zu verdanken, dass ich nun doch noch an meine Mails über einen (entfernten) Mailclient komme. Und das kam so …

Ich habe mal wieder ein defektes Gebrauchtgerät von SW erworben auf dem ich wie selbstverständlich wieder ein Fedora 33 installiert hatte. Diesmal mit Btrfs als Standarddateisystem. Das hatte ich schon eine Zeit lang als BIONC-Client mit einem auf einem 128 GB USB-Stick installierten Fedora genutzt. Nun hab ich das ehemalige Windows auf der Festplatte eben ersetzt und weil es noch keine besondere Aufgabe bekommen hat, hab ich den Thunderbird dort mal gestartet und die Ersteinrichtung auf meinen Mailserver zeigen lassen. Das ging etwas sperrig, weil die Werte alle irgendwie exotisch sind oder vom Server nicht freiwillig herausgegeben wurden, aber letztlich hat das doch geklappt. Und siehe da: alle Mails sind da, alle abonnierten Ordner wurden synchronisiert und alle Mails waren lesbar - nachdem ich einige Konfigurationen auf dem Mailserver wieder zurückgedreht hatte, als ich vor einigen Wochen oder Monaten verzweifelt versucht hatte wieder Zugriff auf meine Mails zu erlangen.

Nachdem ich also den Beweis hatte, dass der Mailserver inzwischen fehlerfrei läuft, konnte es nur noch an meinem Mailclient auf meinem X1 Carbon liegen. Dort hatte ich nun schon mehrmals in den vergangenen Wochen versucht das Mailkonto zu löschen und neu anzulegen. Auch habe ich das Profil im .thunderbird-Ordner zu manipulieren versucht, aber alles war bisher vergebens. Ein hartnäckiger Fehler bestand z. B. darin, dass bei den Eigenschaften des Posteingangsordners des Kontos imap://stippi%40servername@.servername.domain.tld/INBOX stand. Ich hab aber den Eintrag nicht ändern können und nicht herausgefunden wo der herkommt. Ich hab das Konto mehrmals gelöscht und wieder neu angelegt, aber den Fehler nicht herausbekommen. Ich hab sogar von einem funktionieren (Windows-)Client den Inhalt vom Konto aus dem Profil herauskopiert und auf dem X1 ins Profil gebastelt - alles vergebens. Heute dann habe ich es tatsächlich geschafft, alles fehlerhafte sauber aus dem Thunderbird vom X1 herauszulöschen und das Konto ganz sauber wieder anzulegen, so dass es jetzt wieder funktioniert. Daraufhin hab ich sofort ein Backup vom Thunderbird-Profilordner gemacht. Puh, darauf bin ich mächtig stolz, denn jetzt kann ich wieder wie gewohnt meine Mails auf dem Server lesen, die ja schon ziemlich wichtig geworden sind, weil dort die Mails der vergangene Jahre liegen und ich den Server als Archiv benutze. Außerdem räumt der Server nach wie vor zuverlässig alle meine Online-Mailkonten sauber ab, damit sich dort kein Müll ansammelt. Und das Backup funktioniert ja auch noch bestens. Dann hab ich auch gleich noch mal einen Snapshot vom Mailserver genommen, damit ich kein µ an Daten verliere. Puh, geschafft. Und das nach solch schwierigen Wochen mit Homeoffice und Corona-Regeln. Chapeau!

Eine Warnung muss ich allerdings noch loswerden

: In dem .thunderbird-Profilordner herumzufuhrwerken ist keine gute Sache! Wenn man kein Backup hat und sich nicht sicher ist was man tut: FINGER WEG!